HELP, unable to access TOMO on MEW

Yesterday I completed a transaction on, exchanging BTC for TOMO. I provided my MEW address as the destination for the TOMO. The transaction was completed and shows the TOMO was successfully sent to my MEW address.

When I sign into my MEW there is a zero TOMO balance when I select the TomoCoin network or any ETH network. How do I access the TOMO???

Any help would be greatly appreciated as CoinSwitch’s Captcha feature is malfunctioning and conveniently (for them) not allowing me to submit a service ticket on their site.

Thank you in advance!!!


Can you give me your wallet address then I will check your case out better.

Thank you.

Is there a way to DM this rather than adding it to the post?

Thank you for the reply JustinYan.

When I click on someone’s name or avatar I get a pop up that shows their details like post information and badges earned, but no “message” button.

If I click through the user’s name or avatar I get a screen listing out all the user’s badges and other info, but no “message” button or link. I also tried going to the messages center from my profile, but I don’t see a way to send a message out from there either. Any idea why this is the case?

I want to pass along the address, but don’t feel comfortable posting it publicly. Can you DM me directly to start a private thread?

Thank you for any help!!!


I guess the button doesn’t work from your side, it’s still available in Justin’s pop up screen and mine as well.

To make you comfortable to share your private information, I suggest you can reach out to me via Telegram. My handle is Mikeysel32ht. Jot down your handle here then I will check your message better.

Remember that admins never DM you first!

Have a good day and thank you,


I just sent you a note through Telegram. Thank you


I replied your message via DM. Pls check it out.

Thank you.

Hi Tam,

I am having an issue in regards to accessing my TOMO on MEW. It’s available on the ETH network but not the TOMO. I have tried following the advice on TomoChain support but it’s not working. I too cannot find an option to DM in that forum. Could I send u my address for some help?

Thanks :smiley:


My pleasure to connect with you. Please leave the message via Telegram, my handle is MiKeysel32.

Thank you!