How to run private net in tomochain?

i need help to test tomochain in privatenet. please reply

1 Like

Hi there, could you elaborate more?

1 Like

yes, tomo command is not working. do i need to install tomo?

1 Like

Could you be more specific on your issue? Screenshot which step/stage you are on so we will know where the issue comes from.

1 Like

i’m facing this issues

Make sure you add some alias in bashrc or .profile files


do any developer group for tomochain? I’m still not get

Hi, the forum is for the discussion between the team and the community. You can communicate with our developers here. And @TomoTomo is one of our devs. Please elaborate more on your issue so he can help.

i want a easy guide to run private chain. as i already mention tomo command is not working.
for example:- tomo --datadir . init Genesis.json

Here are the documents:

TomoChain Private Testnet Setup

Masternode Setup

For other informations:

Hope this help :slightly_smiling_face:

i have a question did you build something like geth to install. because I’m still facing issues to access tomo command. I’m using ./build/bin/tomo to use tomo command.

or help me to setup tomo to globally in my pc. it really help me.

and 2nd issue is i want to run private chain but it not working it asking me to create masternode first then it work do any process there to disable masternode and run testchain for testing and deploying smartcontract.

thanks in advance😊

No problem, you can set an alias in .bashrc or .profile to use shortcut word tomo

In order to run a private chain, you need some masternodes to create and verify blocks. Once your nodes start creating blocks then you can get private rpc to deploy contract.

hey tomotomo,
do there any issue with this command this command is not working to run masternode. i have un init and it working fine.

./buid/bin/tomo --syncmode "full" \ --datadir Desktop/tomochain/genesis/1 --networkid 108 --port 10303 \ --keystore home/Desktop/tomochain/datadir/keystore/1 --password 12356789 \ --rpc --rpccorsdomain "*" --rpcaddr --rpcport 1545 --rpcvhosts "*" \ --rpcapi "db,eth,net,web3,personal,debug" \ --gcmode "archive" \ --ws --wsaddr --wsport 1546 --wsorigins "*" --unlock "0Xd4a9847143a4fd555cc58cbfe9d318a8a620d7e2" \ --identity "NODE1" \ --mine --gasprice 2500 \ console

You can try with this script

1 Like

okay, got it thanks now. I’m able to run 2node masternode but in my localhost. but i have issue that they are not connecting each other. so i think it might me my firewall issue. then i try to run private net in server. i cloned tomo source code build it using make tomo && make all.

then i create new account and init using build/bin/tomo --datadir datadir init stakechain.json

then i run the chain using

build/bin/tomo --syncmode "full" \ --datadir node1 --networkid 70077 --port 10303 \ --keystore datadir/keystore --password password.txt \ --rpc --rpccorsdomain "*" --rpcaddr --rpcport 1545 --rpcvhosts "*" \ --rpcapi "db,eth,net,web3,personal,debug" \ --gcmode "archive" \ --ws --wsaddr --wsport 1546 --wsorigins "*" --unlock "ddb9e6acfb1375cbaabb51f1cd0a5b829104f334" --password password.txt \ --identity "NODE1" \ --mine --gasprice 2500 \ --bootnodes enode://68244c60469046d777cfb832ad3e7659ffa784a8c202d319109cab7225023db99cc51317431df411e1dff3b5b92e670ac9ad4935ca294755ff6c94541e0ae5f1@ \ console

but it connecting to chainId 88 which is tomo chain id. please help me to resolve. thanks in advance

1 Like

how to resolve this error? List M1 not found

im facing this issue after 1799 blocks. do you please help me to resolve.

im running 3masternode 2are not mining one is mining and other are giving error not my turn. and after 1799 block 1st one is also not mining


TomoChain blockchain is open source. Therefore regarding private network, creator has to fix the coding by his own. We can’t support further case by case. You can explore more here: TomoChain Private Testnet Setup - TomoChain Docs.

Thank you.