Problem Using MetaMask


I have been using MetaMask for more almost 2 years now for all Tomo-related transactions. Since the last update, I am getting this message from MetaMask when I select my Tomo Network:

"Invalid Custom Network

The chain ID for custom network ‘TomoChain’ has to be re-entered.

To protect you from malicious or faulty network providers, chain IDs are now required for all custom networks.

Go to Settings > Network and enter the chain ID. You can find the chain IDs of most popular networks on"

When I go to settings, I see the old config for which I had 88 as Chain ID.

Now there is a little information saying that the Chain ID should start with 0x.

Anyone knows what to input?


I have been helped by community members on Telegram.

We have to use “0x58” instead of “88” as chainid.

I think the team should verify and their side and update the following doc:



Thank you for your suggestion. Let us investigate the case.