Lition Staking wallet Connection Problem

Hey team,

I cannot access my Lition Staking anymore with my Metamask account. It always displays “Unlock your Wallet” even when I am connected to metamask. I am using the staking application for several months now and I never had a problem. So I have not done anything wrong. I am using Chrome. I have over 300k LIT currently staking and it is not displayed anywhere since today. Also my brother cannot reach his LIT holdings aswell.

I am confident that you have not lost our tokens and I would like to know when you have the problem solved.

1 Like

Alright I just saw a tweet about maintenance, so I hope that we will reach the staking application after that. :slight_smile:

Love you guys :heart::heart::heart:

1 Like

Alright guys,

If you have the same problem as me you will be able to solve it temporarly with:

There is a link for a metamask extension.
The problem was that Metamasks updated version was not compatible with Lition Staking application.

Now the Dev Team of Tomochain is updating the Lition Staking application, so very soon the Problem will be solved.

I am so happy that I was able to talk with the Tomo chain team, they are very great people and trustworthy for my money! Awesome! :heart_eyes: :100:


Thank you for sharing the tutorial post and for your great trust :innocent:

We are looking into the staking site and will upgrade it as soon as possible to be compatible with the latest version of Metamask. Meanwhile, you should downgrade your Metamask to continue staking and accessing staking funds.

1 Like