Luaswap within Tomo wallet not connecting to Ethereum

Hi, would the lua/tomo team kindly look into Luaswap within Tomo wallet not connecting to Ethereum network? Screenshot below showing endless loading.

Kindly advise at your earliest as I’m unable to transaction. In addition I can’t move my Ethereum balances to Tomochain since I can’t purchase more Ethereum via luaswap.


1 Like

Hi, could you send me your device info? Regarding your trading activity, I think you could move your token (USDT/TOMO/BTC) to TRC token on TomoChain via TomoBridge and using LuaSwap on TomoChain at a cheaper fee and supper fast confirmation time

Hi, I’m on iPhone X and wallet app version 0.67

Unfortunately I’m unable to move funds to TRC via Tomobridge due to high ETH fee (screenshot 1 below).

And I’m unable to buy more ETH on Luaswap since I have to first have ETH to fund an ETH purchase— which isn’t very usable. Would the tomo/Lua team enable ETH be deducted from purchase rather than pre-fund?

Screenshot 1:


sorry but that function is not available atm. If you have TOMO, the only thing you need to do is go to LuaSwap on TomoChain and swap your TOMO to any token you want with cheap fee

Hi, when will the luaswap connecting to Ethereum issue be fixed? Kindly see screenshot of Tomo wallet app still not connecting

Could you try to refresh and re-open your TomoWallet again, I have checked and it’s working normally from my end

Still not connecting — see image

I tried to wrap to TRC per your suggestion and get the following error in Tomo wallet app Tomobridge. Kindly see screenshot and advise next steps