MetaMask: TransportStatusError: Ledger device: UNKNOWN_ERROR (0x6804)

Hi there, i just ported my a test-coin over to my ledger and tryed to connect it to metamask. I followed this tutorial as ledger mentioned it on there website. I tryed it with 88 and 0x58. I researched a bit and someone had the same issue and fixed it with Allowing Contract Data. I got the same error.

Some specs:
Ledger Nano X with the newest Firmware
Tomo App 1.6.4
OS: Arch Linux with KDE (Yoroi and Ledger Live are working fine)
Browser: Firefox

I hope somebody can help me and appreciate it :smiley:

Sorry but “test-coin” here means TOMO on testnet right? And could you send me the screenshot of your issue?

Sorry for the bad formulation, with test coin I meant that I transferd one coin from the mainnet to the wallet to test if everything works correctly.

I attach the error in this post and the config I made in the next replay as I can only attach one file.

btw, the distro changed from self-installed arch to Garuda.

Thanks in advance!


Here is the config :smiley:

Which app do you use in ledger?

It should be ethereum, tomochain gives you the above error. :rofl:

Ohh, my bad, would you mind explaining?
I don’t get it, why do I need the ethereum app open to use an tomo wallet?

Metamask recognizes ethereum hd derivation paths only(Ledger live and legacy).

Each app in ledger has its own path for its own chain. Tomochain’s path is something 889, so metamask always rejects it.

Ahh, ok, thanks :smiley:

Now I understand ;D